Honda Civic Forums - 7thGenHonda banner
1 - 20 of 20 Posts

·
Registered
Joined
·
1,046 Posts
Discussion Starter · #1 · (Edited)
Hey everyone, finally I got a chance to get this EP3 Cluster DIY. I know there have been a lot of people requesting for it and sorry for the slack I’ve been on. First I would like to begin saying that I am swapping a 02 civic to the EP3 one. I am assuming that the wires are located different from the 04 05 models. The great thing about this swap that I found out was that EP3 cluster pigtail plugs will plug onto our stock cluster. The only thing that you would need to worry about is repining the wires. It took me about 45 minutes to do everything carefully and nicely. Messing with electric wires, please remember to unplug the battery in case you accidently touch the wires together. It would probably blow up a fuse or something else and it will be an ass if you have a shortage somewhere. It didn’t happen to me but just wanna throw this out there.

WARNING: IF YOU DO NOT LIKE TO HAVE GAP SHOWING I WOULDN’T RECOMMEND THIS SWAP FOR YOU. THE EP3 CLUSTER IS SMALLER THAN OURS. DOING THIS SWAP WILL HAVE ABOUT 1.5 INCH OF GAP BETWEEN THE SIDES. PLEASE LOOK AT THE PICS FOR DETAIL. LAST OF ALL DO IT ON YOUR OWN RISK.

I WILL POST UP THE STOCK PINOUT IF PEOPLE WOULD LIKE TO RETURN TO THEIR STOCK CLUSTER

I am writing from what I remember, correct/question me if I say anything thing that may be incorrect or confusing…

Tools needed
Four-Head Screw Driver: Used to unscrew and screw “screws”
Flat-Head Screw Driver: I used this to take off the cluster bazel once I get the screws out.
Paper clip: Taking out the pins off the cluster plugs
Electric tape: If needed

Step 1
If you know how to take off the cluster cover that would be a easy step to get by. Just unscrew the two screws located above the cluster bazel. If you would like to see some pictures of how to do this I will post up some if requested, but I would highly doubt that you will need pics of how to do this.

Step 2
Unscrew the three screws that is holding the cluster in place. Two of the screw is located on the left and right side. The third screw is above, look for it you’ll see it.

Step 3
Unplug the two plugs. The plugs are color green and blue. Once you get them unplug the cluster should be easy to take out.

Step 4
This step you would need to repin both of the plugs. I happen to take all the pins off the pigtail plug and put them in one by one. Here is the wiring diagram…

Color Codes:

RED = Red
BLU = Blue
PNK = Pink
GRN = Green
YEL = Yellow
WHT = White
ORN = Orange
BLK = Black

Examples: RED/BLK= Red wire with black stripe
GRN/WHT = Green wire with white stripe..and so on

The EP3 and EM2 cluster wires are the same color and are the same thing, example, the Red/Blue is High Beam Indicator, on the EM2 and it is same thing on the EP3

EP3 Cluster

Connector A
- BLUE

1. USA, ’02-‘03 Canada: RED/YEL (Fuse 15 – Underhood) ’04-‘05 Canada: RED/GRN (+B L H/L)
2.
3.
4.
5.
6.
7.
8.
9.
10.
11. RED/BLU (High Beam Indicator)
12. BLU/RED (ABS)
13. YEL/BLU (EPS Indicator)
14. PNK (SRS)
15. Side Airbag: PNK/BLU (Side airbag cut-off indicator)
16.
17. Canada: WHT/BLU (Gauges and indicators)
18.
19.
20.
21.
22. GRN/YEL (Right turn signal indicator)

Connector B
- GREEN

1. WHT/RED (Fuse 9 – Under-hood)
2. YEL (Fuse 10 – Under-dash)
3. RED/BLK (Circuit 11)
4. BLU (Circuit E09)
5. BLU/WHT (Circuit E93)
6. RED (Circuit 12)
7.
8. GRN/ORN (DLC and MIL circuits)
9. YEL/RED (Low oil pressure indicator)
10. GRN/RED (Left turn signal indicator)
11. BLK (G502; Ground)
12. BLK (G502; Ground)
13. WHT/GRN (Gauges and indicators)
14.
15.
16.
17. Canada: PNK (Gauges and indicators)
18. YEL/BLK (Gauges and indicators)
19. BLU/ORN (Immobilizer system indicator)
20.
21.
22. BLU/YEL (Cruise Control indicator)

SORRY FOR SOME SLOPPY PICS






I REMEMEBR THERE WAS ABOUT FEW WIRES THAT WAS NOT USE BECAUSE THE EP3 CLUSTER DID NOT HAVE THAT COLOR.

Once you have everything pinned correctly see if it works correctly before putting everything back together.

Here are some pictures of how mines turn out to be like…







SPECIAL THANKS:
Speedfoos (Clint) : Trying to help me find the pin out when I needed them…
asianboi313, CarolinaHondas.com (Fongy) : A friend that has a shop where he has access to most of the wiring diagrams

You can thank me if you want…ahaha I think I am the first one to do this onto our civics.

Video:
http://www.youtube.com/watch?v=mcakl2mSwBs

PLEASE RATE

PLEASE POST PICS OF HOW YOURS TURN OUT TO BE ALSO… AND MOST OF ALL THANKS FOR VIEWING
 

·
Registered
Joined
·
1,046 Posts
Discussion Starter · #5 ·
ill never do a rsx or ep3 cluster swap cause i HATE the gaps they leave it would annoy me :nono:

but great DIY :tup::tup:

whats up with the boost gage chillin? are u boosted?

yea im boosting now, tats why i needed ur aem fic...haha...but i just busted a coupler, need to replace it...:pisschair:
 

·
Registered
Joined
·
1,046 Posts
Discussion Starter · #7 ·
heres some sloppy pics of my turbo build...im running on a stock motor n crap but its alright if i blow it up, i got another motor ready for a build...

sorry so much wires...









heres my other block...its also in my other thread..

 

·
Retired Mod
Joined
·
10,304 Posts
You could always make a fascia out of 1/8" MDF and paint it black to cover up the gap on the side for a low-tech way of fixing it. Or make one out of 'glass.

Good job on the swap now put a filter on that turbo!
 

·
Registered
Joined
·
1,046 Posts
Discussion Starter · #11 ·
haha yea i saw that you had the same wastegate when you was selling ur kit...im boosting stock spring on the wastegate, at least 7-8 pound....but damn bro u needed ur aem fic, but o well...gotta find one soon or if not imma go tune it with my VAFC2....i know its not that best but at least its better than stock...
 

·
Registered
Joined
·
1,046 Posts
Discussion Starter · #12 ·
You could always make a fascia out of 1/8" MDF and paint it black to cover up the gap on the side for a low-tech way of fixing it. Or make one out of 'glass.

Good job on the swap now put a filter on that turbo!
thanks clint, i need to get a pipe that will curve away from the alt. so little space to mess with...haha
 

·
Registered
Joined
·
2 Posts
ahhh where you say it goes to the gauges and indicators.. which one are you talking about because theres 3?:pisschair:e im doing the ep3 cluster install into my 92 hatchback with a gsr dashboard and theres no gap!!! it looks nice oh and p.s. my eg diagram has power fuse 19 but for the ep3 it is fuse 15.... what do i do??? i have the diagram for both clusters from the service manual and ehhhh its not as easy
 

·
Registered
Joined
·
1,046 Posts
Discussion Starter · #14 · (Edited)
ahhh where you say it goes to the gauges and indicators.. which one are you talking about because theres 3?:pisschair:e im doing the ep3 cluster install into my 92 hatchback with a gsr dashboard and theres no gap!!! it looks nice oh and p.s. my eg diagram has power fuse 19 but for the ep3 it is fuse 15.... what do i do??? i have the diagram for both clusters from the service manual and ehhhh its not as easy
are you asking that your eg has 3 gauges and indicators? im not sure what you're asking for, but as far as the power fuse just repin it to the ep3 clusterpigtails
 

·
Registered
Joined
·
2 Posts
wow just repin??? that makes no sense homie... both diagrams have different fuses and locations.. check it out... for the eg cluster there is 2 cables for power fuse 1 and 3 cables for power fuse 19, 1 cable for power so thats 6 power cables.... and now for the ep3 cluster theres 2 for the underhood fuse box, 1 for the ignition and 1 for a fusebox but on the eg diagram it doesnt say which fuse it goes too oh and both diagrams use different fuse numbers!!!!
 

·
Registered
Joined
·
1,046 Posts
Discussion Starter · #16 ·
sorry bro, im not too sure about where it should be pin either:dunno:
 

·
Registered
Joined
·
687 Posts
I try this on my 01 and now I fail..my car wont start and also, there is no number 13. YEL/BLU (EPS Indicator)...but there is a BLU/YEL wire tho...can you also provide the stock pinning too just incase people wants to return to their stock cluster because i sure do wanna go back since the ep3 didnt work..

EDIT: you say you have one or two wires left over but when i tried it, i have 4 wires left over after followinig this diy
 

·
Registered
Joined
·
687 Posts
okay..i figured a way to throw my old pinning back together to get the car running the 01-03 cluster again..but the ABD light is on now...can someone pm me or notify me which slot it go to?
 

·
Registered
Joined
·
1,046 Posts
Discussion Starter · #19 ·
I try this on my 01 and now I fail..my car wont start and also, there is no number 13. YEL/BLU (EPS Indicator)...but there is a BLU/YEL wire tho...can you also provide the stock pinning too just incase people wants to return to their stock cluster because i sure do wanna go back since the ep3 didnt work..

EDIT: you say you have one or two wires left over but when i tried it, i have 4 wires left over after followinig this diy
sorry for the late reply, i just took off my cluster the other day to install a NOS gauge, and yes my mistake it does have more than 2 wires, i apologize for the incorrect information...the stock pinning should be somewhere on here 7thgen, its in one of the 01-03 to 04-05 cluster swap, i can repost the pining again if wanted...
 

·
Registered
Joined
·
3 Posts
works perfectly the thread that you have left, it has a duplicate for the thread fuse box white / red and the other apprès verification seems to come for the trans at tanks to be tutorial if you ever update it send me a message there corection to do ;)
 
1 - 20 of 20 Posts
Top